Scrapy Cloud performance degradation

Incident Report for Zyte

Resolved

This incident has been resolved.
Posted Aug 14, 2025 - 20:22 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Aug 13, 2025 - 14:36 UTC

Investigating

We are currently investigating a performance degradation regarding Scrapy Cloud jobs.
Posted Aug 13, 2025 - 07:05 UTC
This incident affected: Scrapy Cloud (Scrapy Cloud - Job Execution and Storage).