Performance degradation in Periodic jobs scheduling and deployment

Incident Report for Zyte

Resolved

This incident has been resolved.
Posted Aug 17, 2026 - 12:41 UTC

Investigating

We are currently experiencing issues with the Periodic jobs scheduling and deployment. We are investigating about this issue and will keep you posted.
Posted Aug 17, 2026 - 09:05 UTC
This incident affected: Scrapy Cloud (Scrapy Cloud - Project Deployment, Scrapy Cloud - Periodic Job Scheduling).