Between 07:00 AM and 09:27 AM UTC, we experienced increased error rates and latency across multiple services due to an AWS outage specifically related to a DNS resolution issue impacting DynamoDB.
Our systems have now recovered, and services are mostly operating normally. We will continue to monitor and provide further updates as needed.
Posted Oct 20, 2025 - 11:20 UTC
Update
We are continuing to work on a fix for this issue.
Posted Oct 20, 2025 - 10:04 UTC
Identified
We are experiencing some difficulties with our services due to our AWS provider having an incident. Please note that this is outside of control and we are looking into restoring all our services fully as soon as possible.
Posted Oct 20, 2025 - 10:03 UTC
This incident affected: Web Dashboard, Support Center and Zyte API (Zyte API).