Issue with adding Payment Method via Dashboard
Incident Report for Zyte
Resolved
This incident has been resolved.
Posted Dec 20, 2023 - 00:02 UTC
Monitoring
We have rolled out a solution for the observed issues and our sign up process is now fully operational, thanks you again for your patience.
Posted Dec 19, 2023 - 17:33 UTC
Investigating
New Zyte users are currently subject to experiencing difficulties signing up when adding new credit cards. We’re currently investigating the underlying issues to restore the sign up process as soon as possible. We apologize for any inconvenience.
Posted Dec 19, 2023 - 15:29 UTC
This incident affected: Web Dashboard.