Zyte API – Performance Degradation

Incident Report for Zyte

Monitoring

A fix has been implemented, and we are currently monitoring the results.
Posted Sep 10, 2026 - 06:28 UTC

Investigating

We are currently experiencing degraded performance with Zyte API Browser Rendering. Customers using Browser Rendering may experience increased latency, failed requests (520s), or reduced success rates.

Our team is actively investigating the issue and working to minimize the impact. We will provide further updates as soon as more information becomes available. We apologize for the inconvenience and appreciate your patience.
Posted Sep 10, 2026 - 05:28 UTC
This incident affects: Zyte API (Zyte API).