We are continuing to monitor for any further issues.
Posted Mar 21, 2025 - 03:56 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Mar 21, 2025 - 03:33 UTC
Investigating
We are currently experiencing a service degradation affecting Scrapy Cloud. You may encounter issues with job execution, scheduling, or retrieving items via the Scrapy Cloud API key, due to a problem with our backend service discovery system. Our team is actively working to resolve the issue.