Contact Support form unavailable
Incident Report for Zyte
Resolved
This incident has been resolved.
Posted May 06, 2022 - 08:01 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted May 05, 2022 - 16:44 UTC
Investigating
We are currently investigating an issue regarding our "Contact Support" form. Some users might encounter a "Sorry, it appears something went wrong" page when trying to access our Support portal. If you already have an open ticket you can reply to us via email. Apologies for the inconveniences caused.
Posted May 03, 2022 - 23:33 UTC
This incident affected: Support center.