HubStorage API is having downgraded performance
Incident Report for Zyte
Resolved
Job Execution and Data storage issue has been resolved.

Sorry for the Inconvenience casused due to the issue!
Posted Jun 09, 2021 - 10:07 UTC
Monitoring
We have identified the issue and implemented a fix. We are currently monitoring the results.
Posted Jun 09, 2021 - 06:14 UTC
Update
We are continuing to investigate this issue.
Posted Jun 09, 2021 - 06:13 UTC
Investigating
We are currently investigating this issue.
Posted Jun 08, 2021 - 20:59 UTC
This incident affected: Job execution & data storage.